Remote Access for Siemens PLC(s) 
Through SIMATIC Step7®

APPLICATION NOTE
AUG-0037-00 2.3 en-US ENGLISH
Important User Information

Disclaimer

The information in this document is for informational purposes only. Please inform HMS Industrial Networks of any inaccuracies or omissions found in this document. HMS Industrial Networks disclaims any responsibility or liability for any errors that may appear in this document.

HMS Industrial Networks reserves the right to modify its products in line with its policy of continuous product development. The information in this document shall therefore not be construed as a commitment on the part of HMS Industrial Networks and is subject to change without notice. HMS Industrial Networks makes no commitment to update or keep current the information in this document.

The data, examples and illustrations found in this document are included for illustrative purposes and are only intended to help improve understanding of the functionality and handling of the product. In view of the wide range of possible applications of the product, and because of the many variables and requirements associated with any particular implementation, HMS Industrial Networks cannot assume responsibility or liability for actual use based on the data, examples or illustrations included in this document nor for any damages incurred during installation of the product. Those responsible for the use of the product must acquire sufficient knowledge in order to ensure that the product is used correctly in their specific application and that the application meets all performance and safety requirements including any applicable laws, regulations, codes and standards. Further, HMS Industrial Networks will under no circumstances assume liability or responsibility for any problems that may arise as a result from the use of undocumented features or functional side effects found outside the documented scope of the product. The effects caused by any direct or indirect use of such aspects of the product are undefined and may include e.g. compatibility issues and stability issues.
# Table of Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Preface</td>
<td>3</td>
</tr>
<tr>
<td>1.1 About This Document</td>
<td>3</td>
</tr>
<tr>
<td>1.2 Document history</td>
<td>3</td>
</tr>
<tr>
<td>1.3 Related Documents</td>
<td>3</td>
</tr>
<tr>
<td>1.4 Trademark Information</td>
<td>3</td>
</tr>
<tr>
<td>Requirements</td>
<td>4</td>
</tr>
<tr>
<td>2.1 Hardware</td>
<td>4</td>
</tr>
<tr>
<td>2.2 Software</td>
<td>4</td>
</tr>
<tr>
<td>Objective</td>
<td>5</td>
</tr>
<tr>
<td>Prepare your Ewon for Remote Access</td>
<td>6</td>
</tr>
<tr>
<td>Configure your Ewon for Remote Access</td>
<td>7</td>
</tr>
<tr>
<td>5.1 Step 1: Create your Ewon in Talk2M</td>
<td>7</td>
</tr>
<tr>
<td>5.2 Step 2: Prepare the Configuration File</td>
<td>9</td>
</tr>
<tr>
<td>5.3 Step 3: Apply the Configuration File</td>
<td>10</td>
</tr>
<tr>
<td>5.4 Step 4: Connect to your Ewon Remotely</td>
<td>11</td>
</tr>
<tr>
<td>5.5 Step 6: Terminate the Remote Connection</td>
<td>13</td>
</tr>
<tr>
<td>Link an Ewon to the PLC</td>
<td>15</td>
</tr>
<tr>
<td>6.1 MPI/Profibus Port Configuration</td>
<td>15</td>
</tr>
<tr>
<td>6.2 Ethernet ISOTCP Configuration</td>
<td>16</td>
</tr>
<tr>
<td>PLC Software Mapping</td>
<td>18</td>
</tr>
<tr>
<td>7.1 MPI Link</td>
<td>18</td>
</tr>
<tr>
<td>7.2 Ethernet ISOTCP Link</td>
<td>28</td>
</tr>
<tr>
<td>PLC Remote Access</td>
<td>31</td>
</tr>
<tr>
<td>Troubleshooting</td>
<td>32</td>
</tr>
<tr>
<td>9.1 Cannot reach the PLC on its MPI/Profibus port</td>
<td>32</td>
</tr>
<tr>
<td>9.2 Cannot reach Ethernet ISOTCP PLC</td>
<td>32</td>
</tr>
</tbody>
</table>
A Configure your Ewon for Remote Access using the Web Interface ........................................... 33
   A.1 Step 1: Set the LAN IP Address of your Ewon ................................................................. 33
   A.2 Step 2: Configure the Ewon Internet Connection ............................................................ 36
   A.3 Step 3: Create Your Ewon in Talk2M .......................................................... 39
   A.4 Step 4: Retrieve the Talk2M Activation Key ................................................................. 39
   A.5 Step 5: Connect Your Ewon to Talk2M ........................................................................ 41
   A.6 Step 6: Connect to Your Ewon Remotely ................................................................. 42
   A.7 Step 7: Terminate the Remote Connection ................................................................. 43

B Ewon as PLC Gateway ........................................................................................................ 44
   B.1 Phase 1: Online Communication with the PLC ......................................................... 45
   B.2 Phase 2: Embed the IP Config. in the PLC ................................................................. 48

C Security Aspects .............................................................................................................. 53
   C.1 Login security ............................................................................................................. 53

D Types of MPI / Profibus Cables ..................................................................................... 55
   D.1 Cable MPI ..................................................................................................................... 55
Preface

1.1 About This Document

This document explains in a few steps how to configure your Ewon device, your Talk2M account and the PLC software to access the Siemens PLC for remote diagnosis and programming.

For additional related documentation and file downloads, please visit www.ewon.biz/support.

1.2 Document history

<table>
<thead>
<tr>
<th>Version</th>
<th>Date</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.0</td>
<td>2011-05-12</td>
<td>First release</td>
</tr>
<tr>
<td>2.0</td>
<td>2011-05-30</td>
<td>Security Aspect (Appendix 2) added</td>
</tr>
<tr>
<td>2.1</td>
<td>2011-06-01</td>
<td>Automated IP config recognition (eCatcher/Talk2M part)</td>
</tr>
<tr>
<td>2.2</td>
<td>2011-06-23</td>
<td>Plug'nRoute impact - changed 6.3 partly moved to Appendix 2, 9.3 moved to Appendix 2, Cosmetic corrections.</td>
</tr>
<tr>
<td>2.3</td>
<td>2019-03-22</td>
<td>Added: Talk2M easy setup</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Changed: new layout added</td>
</tr>
</tbody>
</table>

1.3 Related Documents

<table>
<thead>
<tr>
<th>Document</th>
<th>Author</th>
<th>Document ID</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ewon Configuration for Internet Access Using the Wizard</td>
<td>HMS</td>
<td>AUG-0019-00</td>
</tr>
<tr>
<td>Easy Commissioning via SD Card and USD Drive</td>
<td>HMS</td>
<td>AUG-0062-00</td>
</tr>
<tr>
<td>PLC Discovery through Talk2M</td>
<td>HMS</td>
<td>AUG-0070-00</td>
</tr>
<tr>
<td>WAN ConnectionFallback</td>
<td>HMS</td>
<td>KB-0286-00</td>
</tr>
</tbody>
</table>

1.4 Trademark Information

Ewon™ is a registered trademark of HMS Industrial Networks SA. All other trademarks mentioned in this document are the property of their respective holders.
2 Requirements

2.1 Hardware
To complete this guide, you need the following items:

- an Ewon with VPN capabilities,
- Siemens PLC,
- a computer to configure the Ewon and the Siemens PLC.

2.2 Software

2.2.1 Ewon Related
The following pieces of software are needed to configure your Ewon:

- a modern web browser (min. version: Firefox 15, Chrome 16, Safari 6 and Edge 13),
- eBuddy: Ewon configuration and maintenance utility.
- eCatcher: Talk2M remote access utility. Version 6.4 or higher.

2.2.2 Siemens Related

- SIMATIC Step7: the version of the software must allow the use of the TCP/IP interface (version 5.3 or higher).

We assume the use of VIPA devices in combination with SIMATIC Step7. Even if we don’t document it, you can probably achieve the same tasks in combination with VIPA’s software “WinPLC7”.

Remote Access for Siemens PLC(s)  AUG-0037-00  2.3 en-US
3 

Objective

The objective of this document is to guide you through the steps required to enable remote access of the Siemens.

The remote access setup is composed of 4 different parts:

• communication with the Ewon through the Internet,
• connection of your Ewon to the Siemens PLC,
• configuration of the PLC software so it can communicate through the Ewon,
• access to your PLC through the Internet.

If you connect to an Ewon for the first time, we recommend reading the “Quick Start Guide” document shipped with your Ewon.
4  Prepare your Ewon for Remote Access

The LAN IP address of your Ewon and of your PLC must be in the same IP range.

If you choose the Ethernet or Wi-Fi WAN interface to connect to the Internet, the Ewon requires a LAN IP address on the machine side and a WAN IP address on the network (remote site) side.

Before configuring your Ewon LAN IP address and by consequence, the IP address of your PLC, ask to your network administrators what is the specified company LAN network range used as WAN connection by the Ewon to connect to the Internet.

The LAN ports of your Ewon and thus the PLCs plugged in the Ewon must be in a range outside the ones used by the Site LAN.

Fig. 1  IP ranges involved in an Ethernet / Wi-Fi network.

In the above example, we could select IP addresses in the 192.168.0.# range for the Ewon LAN and PLCs since it does not overlap with the Site LAN range.

If you choose the cellular WAN interface to connect to the Internet, the Ewon requires only a LAN IP address compatible with the PLC IP address.
5 Configure your Ewon for Remote Access

This section explains how to configure the remote access of your Ewon through Talk2M service.

Before going through the configuration of your Ewon to set the remote access, we recommend reading the Prepare your Ewon for Remote Access, p. 6.

5.1 Step 1: Create your Ewon in Talk2M

The first step consists in listing your Ewon inside your Talk2M account using the eCatcher software.

If you already created your Ewon in your Talk2M account, through eCatcher, you can skip this step and go to the next step.

To create your Ewon in Talk2M, apply the following procedure:

1. Connect your computer to the Internet.
2. Verify that you have an Internet connection.
   For example: open your web browser and browse to your favorite web page.
3. Open eCatcher and log in to your Talk2M account.
   If you don’t have any Talk2M account, please follow the video tutorial “Create a Talk2M Account” available on the Ewon elearning platform.

Fig. 2 Add an Ewon in eCatcher — 1
4. On eCatcher’s main interface, click the +Add icon. A new window appears.

![Image showing the +Add icon in eCatcher]

Fig. 3 Add an Ewon in eCatcher — 2

5. Enter the name of your Ewon.

The Talk2M server displays this name to identify the remote connection to your Ewon.

6. Select the Connection Type to specify how your Ewon connects to the Talk2M server. You can choose between two possibilities:

- Permanent: for Ethernet, Wi-Fi or cellular models. Your Ewon stays permanently online.
- Triggered: only for cellular models. Your Ewon is offline (but still functional) until you wake it up with an SMS.

If you specify a triggered connection, then eCatcher asks for the phone number of your Ewon. The phone number allows Talk2M to send an SMS which wakes up your Ewon.

![Image showing the Connection Type selection in eCatcher]

Fig. 4 Add an Ewon in eCatcher — 3

7. Click Next.
8. Enter custom information concerning your remote connection. You can use the **Custom Fields** to classify or filter your different remote connections (your different Ewons).

![Fig. 5 Add an Ewon in eCatcher — 4](image)

9. Click **Create**.

The newly created Ewon is now linked to your Talk2M account.

![Fig. 6 Talk2m Connectivity in eCatcher](image)

If you have a Talk2M Pro account, you need to add the Ewon to a pool/group of Ewons before being able to create the new Ewon entry.

eCatcher displays the “Talk2M Connectivity” frame. Follow the **Step 2: Prepare the Configuration File, p. 9** to continue the configuration of the remote access.

---

5.2 **Step 2: Prepare the Configuration File**

To access remotely your Ewon, you need to configure the Internet and the Talk2M VPN connection of your Ewon.
Configure your Ewon for Remote Access

The configuration explained in this section uses the Talk2M Easy Setup feature embedded in the eCatcher (as of v6.4). If you wish to configure your Ewon through eBuddy and Ewon web interface, please refer to Configure your Ewon for Remote Access using the Web Interface, p. 33 from the Appendix.

eCatcher offers the possibility to create a commissioning file which includes all the configuration parameters useful to configure such connections.

eCatcher stores the commissioning file on an SD card or a USB flash drive. You can then insert the SD card or USB flash drive in your Ewon which automatically applies the configuration parameters available on the SD card / USB flash drive.

To apply the following configuration, your Ewon must run (minimum) Ewon firmware version 13.2s0 for the USB drive and 11.0s0 for the SD card.

Once eCatcher displays the “Talk2M Connectivity” frame, apply the following procedure:

1. Insert an SD card or USB flash drive in your computer. Make sure the card or the key is of FAT32 format.
2. Click the Launch Setup Wizard button of the USB / SD Card first row.
3. Select the WAN interface of your Ewon.
4. Depending on the interface you choose, different configuration fields are required:
   - Ethernet: WAN IP settings.
   - Wi-Fi: SSID settings.
   - Cellular: SIM card and APN settings.
   For Ethernet and Wi-Fi, make sure to complete the advanced settings if necessary.
5. Click Next.
6. Set the LAN IP address of your Ewon. Check Prepare your Ewon for Remote Access, p. 6 for more information.
7. Click Next.
8. Select the location where eCatcher should export the file.
9. Click Save twice to confirm the export.

The last screen is an explanation how to proceed with the SD card / USB flash drive and your Ewon. You can also follow Step 3: Apply the Configuration File, p. 10.

5.3 Step 3: Apply the Configuration File

The following configuration works only if your Ewon hasn’t been registered on Talk2M (or is not currently linked to a Talk2M account).

To configure your Ewon for remote access, apply the following procedure:

1. Make sure your Ewon is powered on.
2. Insert the SD card or the USB flash drive in your Ewon.
   The Ewon detects the insertion in a very short period (5 seconds maximum) and you can visualize this detection by the quick orange blinking pattern of the USR LED (ON / OFF each 150 msec).

3. Wait for the Ewon to process the configuration files.
   After the detection of your SD card or USB flash drive, comes the process of what inside. You can visualize the process of the files by the slow orange blinking pattern of the USR LED (ON / OFF each second).

4. Check the status of the USR LED.
   After the process of the configuration files, your Ewon shows if it was able to apply the configuration. The result is as follows:
   - solid green: success
   - solid red: failure

5. Remove the SD card or the USB flash drive. The removal induces the reboot of the Ewon.
6. Within 2 minutes after the reboot, your Ewon should be online in eCatcher.
   You can find a complete explanation on the Ewon easy commissioning with the “Easy Commissioning via SD Card and USD Drive” document from Related Documents, p. 3.

5.4 Step 4: Connect to your Ewon Remotely

Now that the Ewon is connected to Talk2M, you can establish the remote connection to this Ewon.

Depending on the type of connection you set, the procedure changes.

5.4.1 Permanent Connection

To connect remotely to an Ewon tagged as permanent connection, follow the procedure:

1. Connect your computer to the Internet.
2. Verify that you have an Internet connection.
   For example: open your web browser and browse to your favorite web page.
3. Open eCatcher (if not already opened).
4. Select the Ewon you just configured in the “My Ewons” list.
5. Click the green **Connect** button displayed in the Ewon list menu to establish the remote connection. eCatcher is now attempting to establish a VPN connection to the Talk2M server.

6. Once the VPN connection established, eCatcher displays the Ewon in the “Active connection” section.

The computer is now connected to the Ewon using the VPN tunnel and you can use the remote connection.

You can click the **IP address** link in the “Active Connection” section to display, in a web browser, the homepage of the Ewon web interface.

### 5.4.2 Triggered Connection

To connect remotely to an Ewon tagged as triggered connection, follow the procedure:

1. Connect your computer to the Internet.
2. Verify that you have an Internet connection.
   For example: open your web browser and browse to your favorite web page.
3. Open eCatcher (if not already opened).
4. Select the Ewon you just configured in the “My Ewons” list.
5. Click the green **Wake up** button displayed in the Ewon list menu to wake up your Ewon.

By doing so, eCatcher sends an SMS to switch your Ewon online.

6. Click the green **Connect** button (previously **Wake up** button) displayed in the Ewon list menu to establish the remote connection. eCatcher is now attempting to establish a VPN connection to the Talk2M server.

7. Once the VPN connection established, eCatcher displays the Ewon in the “Active connection” section.

   With your smartphone, you can also send the SMS “Talk2M_Connect” or “Talk2MConnect” to your Ewon to wake it up.

The computer is now connected to the Ewon using the VPN tunnel and you can use the remote connection.

You can click the **IP address** link in the “Active Connection” section to display, in a web browser, the homepage of the Ewon web interface.

### 5.5 Step 6: Terminate the Remote Connection

![Image](https://via.placeholder.com/150)

Before terminating the Talk2M VPN connection to the Ewon, it is mandatory to change the administrator password which is set by default to *adm*. Please refer to *Login security*, p. 53.
To end the VPN connection and so the remote access to your Ewon, apply the following procedure:

1. Open eCatcher while you are remotely connected to your Ewon.
2. Click the red **Disconnect** button to terminate the remote access.
3. Optionally, leave a log message for future use.

You are now disconnected from your Ewon and can no longer use the remote access.

---

> By disconnecting, you terminate only the VPN tunnel. If you also want to send your Ewon offline (in case of a triggered Ewon), right-click on the Ewon in eCatcher and select **Go offline**.
6 Link an Ewon to the PLC

You can connect an Ewon to an (or multiple) S7-family PLC using the Ewon MPI/Profibus port or the Ewon Ethernet ISOTCP port(s).

The configuration of the Ewon can be slightly different if the connection between the PLC and the Ewon is MPI/Profibus- or Ethernet ISOTCP-based.

You can combine both connection types without any problem.

The limit of concurrent connection through ISOTCP is set to 32.

6.1 MPI/Profibus Port Configuration

The following configuration applies only to an Ewon Flexy 203 or the Ewon Flexy 205 with the Flexy extension card: FLC 3701.

One of the protocol supported by the Ewon to connect to a Siemens is the MPI / Profibus protocol.

To configure the MPI/Profibus link, follow the procedure:

1. Go to the web interface of your Ewon either using eCatcher (refer to Step 6: Connect to Your Ewon Remotely, p. 42) or by a local point-to-point connection to the LAN port of the Ewon.
2. Go to Tags > IO servers.
3. Open the **S73&400** IO server configuration page.

4. Set the **Protocol Type, Baud Rate, Reply Timeout** and **MPI/Profibus Highest Station Address** parameters as defined in your PLC.

   *The MPI/Profibus address is the MPI address of your Ewon device, not the one of the PLC. The MPI/Profibus address has to be an MPI address not yet used on the MPI network. In most cases the default value 0 works fine*

5. Click the **Update** button to save your settings.

6. Connect the MPI port of the Ewon to the MPI port of the PLC.

   If your Ewon runs a firmware version higher or equals than 12.0, continue the procedure. Otherwise, skip this step 7.

7. For firmware version 12.0 or higher: check the list of neighbors MPI/PROFIBUS stations registered on network.

   You might need to refresh the page to see the list of neighbors.

   ![List of neighbors MPI/PROFIBUS stations registered on network](image)

   *Fig. 13  List of neighbors MPI/PROFIBUS stations registered on network*

   If your Ewon runs a firmware version lower than 12.0, apply the following procedure:

8. Click on the **Destination MPI Node** link to check if the Ewon MPI interface is correctly configured and connected to the MPI network.

   The **MPI Status Info** that shows up, displays the different MPI devices detected by the MPI chip of the Ewon. The ID numbers of the detected MPI/Profibus master devices are highlighted.

   If the status table does not display any MPI address, then the MPI IO server setup parameters for your Ewon are not correct. Or those parameters have not been saved using the **Update** button. Check the baud rate settings, verify that the Ewon is not using an MPI address already in use and make sure you finish the verification by clicking the **Update** button.

   If the status table displays only one MPI address, which is actually the one of your Ewon, it is likely that the baud rate settings are not correct, that your Ewon is not properly connected to the MPI network or that the cable used is not OK.

### 6.2 Ethernet ISOTCP Configuration

As of Ewon firmware 13.2s1, your Ewon embeds a feature called **PLC Discovery**.

The **PLC Discovery** allows the automatic detection of PLC(s) linked to an Ewon on the network while you are connected through Talk2M even if the PLC and the Ewon are not in the same IP range.
For more detail, please refer to the “PLC Discovery through Talk2M” from the Related Documents, p. 3.

The PLC Discovery does not prevent you from configuring the Ewon and the PLC to be in the same IP range. The Ewon and the PLC in the same IP range is a requirement to make the remote access successful.

In most cases, it is no longer necessary to set the Ewon as gateway in the PLC. However, if you need to do so, please refer to Ewon as PLC Gateway, p. 44.
7 PLC Software Mapping

7.1 MPI Link

1. Start SIMATIC Step7® software.
2. Open your existing or a new PLC project.
3. Select Options > Set PG/PC Interface.

4. Select the TCP/IP interface that your computer uses.

   In the illustration below, we chose the TCP/IP(Auto) interface (picture on the left), but depending on your machine, you might have to select TCP/IP(Auto) → hardware identifier (picture on the right).

5. Click on Properties.

6. Open the IE-PG Access tab.
7. Select **Do not assign IP addresses automatically.**
   Click on **OK** to close the properties page.

![Fig. 16 IP address attribution](image1)

8. Back on the **Set PG/PC Interface** window, click **OK** to set the PC/PG interface.

9. Click **OK** to accept the changes.

![Fig. 17 Set the configuration](image2)

10. Download one of the following configuration files from Ewon support web site:
    - **Ewon.cfg**: Ewon gateway station file for Step7® if you run SIMATIC® on a PC that does not feature WinCC.
    - **Ewon_WinCC.cfg**: Ewon gateway station file for Step7® if you run SIMATIC on a PC that features WinCC.
11. Open the **Network Configuration NetPro** utility of your Step7® project.

   You can access **NetPro** either by clicking the icon or by selecting the menu options **Options > Configure Network**.

   ![Access to Netpro](image1)

12. Go to **Edit > Import** and import the Ewon gateway station file — ewon.cfg file (without WinCC) or ewon-wincc.cfg (with WinCC) — downloaded previously.

   Check the **Export file to a station** box and select the Ewon gateway station file. The notion of export can be confusing as you are actually importing a device configuration.

   ![Import configuration file](image2)

![Diagram of Ewon gateway in NetPro](image)

If the Ewon, the PLC and the PG are all connected on the same network through Ethernet, *Step7* will always try to use the Ethernet connection which will fail as the PLC is connected through MPI. Make sure that if an Ethernet connection is used on the PLC, both PLC and Ewon are on different IP range.

14. Click and drag the **red square** of the Ewon to the MPI network of your S7 PLC. This links the MPI interface of your Ewon to the MPI network.

![Diagram of linking MPI interfaces](image)
15. Open the MPI interface of the Ewon with a double-click on the **red square**. 
Check if the **MPI address**, the **transmission rate** and the **Subnet-ID** are correctly set. You can use the **Properties** button for more details. 
Click **OK** to close the two **Properties** window.

**Fig. 23** Properties of the MPI interface

16. Double-click on the **green square** of the Ewon to configure the Ethernet interface.
Do not check **Set MAC address / use ISO protocol**.

Enter the **IP address** of the Ewon which is used for the remote connection (in our example 192.168.0.53).

Enter the **subnet mask** corresponding to the IP address you specified for the Ewon (in our example 255.255.0.0). In some cases, Step7® can find the desired subnet masks inconsistent. Step7® rejects then the subnet and forces you to accept (for example) 255.255.255.0. You can accept as it does not harm the connection capability.

[Optional] Modify the **Ethernet subnet** name.
Click **OK** twice to close the two **Properties** windows.

**Fig. 24** Configuration of the Ethernet interface
17. Go to **Insert > Network Objects** to add a PG/PC Station to the network layout. Double-click on the **PG/PC Station**. NetPro adds an unconnected PG/PC station in the network pane.

![Fig. 25 PG/PC Station](image)

18. Right-click on the **PG/PC** frame. Click on **Object Properties** and select the **General Interfaces** tab. Click on **New**.

![Fig. 26 PG/PC Properties](image)
19. Select *Industrial Ethernet*, and click **OK**.

![New Interface - Type Selection](image)

**Fig. 27 Industrial Ethernet interface**

20. Click the **Properties** button of the newly added Ethernet interface.

In the parameter tab, make sure the **Set MAC address / use ISO protocol** is **NOT** selected.

Set the **IP address** and **the subnet mask** of your PC.

Check the **Do not use router** box.

In the **Subnet** window on the bottom of the page, select **the network** your Ewon is connected to (e.g.: in our example, we named it *Ewon Gateway Ethernet*).

Click **OK** twice to close the two **Properties** windows.

![Properties - Ethernet Interface](image)

**Fig. 28 Properties of the Ethernet interface**

In this case, the computer owns a LAN IP address which is in the same range as the Ewon. For local configuration, this has no impact. However, if you perform a remote connection with these settings, you will be facing IP conflicts. For more details, refer to *Prepare your Ewon for Remote Access, p. 6*. 
21. NetPro adapts its viewport based on the current configuration.

![NetPro viewport](image1)

Fig. 29 NetPro viewport

22. Right-click the **PG/PC** frame and click on **Assign PG/PC**.

![PG/PC assignment](image2)

Fig. 30 PG/PC assignment
23. In the **Interface Parameter Assignments** section from the PG/PC properties, select the **TCP/IP** interface you are using to connect to the Ethernet. 

   Click the **Assign** button.

![Fig. 31 PG/PC — Interface parameter assignment](image)

24. [Optional] In some cases, an alert is displayed. You can ignore this message and click **OK**.

![Fig. 32 Message alert for PG/PC application](image)
25. Verify that the Assigned Interface is the Ethernet card and click OK.

![Fig. 33 Interface assignment](image)

The yellow link on top of the PG/PC shows that this object will be used to go out on the network. The orange background behind the other objects are meant to warn you that the latest modifications have not been saved nor compiled yet.

26. Go to **Network > Save and Compile** to compile and save the network layout of your project.

Select **Compile and check everything** if you want to have NetPro reporting errors (recommended if this is your first experience). You can select **Compile changes only** if you feel confident that everything is correctly configured.

Click **OK**.

![Fig. 34 Save the project](image)
27. A popup appears after the compilation to inform you if the compilation succeeded or not. Warning messages are only informative and may usually be discarded. Error messages reflect real network configuration problems.

28. NetPro reflect the final situation.

Fig. 35 Final configuration of NetPro

29. Close the NetPro window.

7.2 Ethernet ISOTCP Link

To configure your PLC using an Ethernet link, follow the procedure:

1. Start SIMATIC Step7® software.
2. Open your existing or a new PLC project.
3. Select **Options > Set PG/PC Interface**.

![Image of SIMATIC Manager interface with highlighted options](image)

**Fig. 36 Selection of PLC interface**

4. Select the TCP/IP interface that your computer uses.
   
   In the illustration below, we chose the TCP/IP(Auto) interface (picture on the left), but depending on your machine, you might have to select TCP/IP(Auto) → hardware identifier (picture on the right).

![Image of Set PG/PC Interface with hardware identifier](image)

**Fig. 37 Apply an interface**

5. Click on **Properties**.

6. Open the **IE-PG Access** tab.
7. Select *Do not assign IP addresses automatically.*

Click on **OK** to close the properties page.

8. Back on the *Set PG/PC Interface* window, click **OK** to set the PC/PG interface.

9. Click **OK** to accept the changes.
8 PLC Remote Access

Before going through this chapter, you must go through the Link an Ewon to the PLC, p. 15 chapter.

Your PLC and your Ewon are physically connected either by MPI or by Ethernet ISOTCP connection.

The steps below are the same for both connection types:

1. Establish the remote connection to the Ewon as explained in Step 6: Connect to Your Ewon Remotely, p. 42.

2. Start SIMATIC STEP7® once eCatcher has established the Talk2M VPN tunnel towards your Ewon.

3. Open the project and make sure you can connect with the PLC by running one of the tasks requiring communication (e.g.: right-click on the CPU in the object tree, select PLC and set Time of Day).

4. Check the date/time returned by the PLC internal clock (under Module time): if the connection is OK, the date/time should be incriminating.

Your setup is connected and ready to work in remote programming mode.

Once you finished your work with SIMATIC STEP7®:

- terminate the SIMATIC Step7® connection through View > Offline and close the application.
- terminate the Talk2M connection of the Ewon as explained in Step 7: Terminate the Remote Connection, p. 43.
9 Troubleshooting

9.1 Cannot reach the PLC on its MPI/Profibus port

If you cannot reach the MMPI/Profibus PLC connected to the Ewon then verify the following items:

- Check the IO server configuration in your Ewon which concerns the S73&400 or S7 and associated protocol settings. See MPI/Profibus Port Configuration, p. 15.
- Open the Ewon Event Log located at Main Menu > Diagnostic > Event Log to check for error messages.
- Check if the PLC has the correct IP address in SIMATIC Step7®. Use either the Ewon LAN IP address or the Ewon VPN IP address.

9.2 Cannot reach Ethernet ISOTCP PLC?

If you cannot reach your PLC through Ethernet, it might be because of the following reasons:

- You did not reboot the PLC after you modified the IP address and/or the gateway.
- There is a possible mismatch between your Ewon’s current IP address and the LAN IP address of your Ewon recorded in the Talk2M account.

  Check these settings in eCatcher and, if necessary, modify them. To do so, select your Ewon in eCatcher and hit the Properties button, then click on the Modify LAN subnet button.

  Disconnect and reconnect to your Ewon in eCatcher to apply the modification.

To verify if the Ewon port and the Ewon IO server are correctly configured, you can create a tag inside the Ewon which polls a register from the PLC. If the polling succeeds, the PLC connection works correctly.
A Configure your Ewon for Remote Access using the Web Interface

This section explains how to configure the remote access of your Ewon through Talk2M with the help of eBuddy and Ewon web interface.

Before going through the configuration of your Ewon to set the remote access, we recommend reading the Prepare your Ewon for Remote Access, p. 6.

A.1 Step 1: Set the LAN IP Address of your Ewon

Once you have selected your IP addresses, you can start configuring your Ewon.

In our example, the Ewon is set to LAN IP address 192.168.0.53. This address fits into the PLC range and does not interfere with the Company LAN.

Fig. 41 Example of IP addresses involved

In this step, there is no constraint on the IP range of your computer.

To configure the LAN IP address of your Ewon:
1. Link your computer to the LAN port of your Ewon.
   Usually, this link is made through the company network but it can also be made with a point-to-point link.

![Fig. 42 Connect the computer indirectly to the Ewon though Company LAN](image1)

2. Open eBuddy.
   eBuddy can display your Ewon in its list even if your computer has a different network address range than your Ewon.

3. Highlight (click on) your Ewon in the eBuddy list.

![Fig. 43 Connect the computer directly to the Ewon](image2)

![Fig. 44 eBuddy — Selection of the Ewon](image3)
4. Click the **Set IP** button.

![Fig. 45 eBuddy — Set IP button](image)

5. Set the **Serial Number** of your Ewon if the field is empty.

![Fig. 46 eBuddy — Serial number field](image)

If you don’t know your Ewon’s serial number, you can look it up on the right side of the Ewon itself.

6. Click **Next**.

7. Set the new LAN IP address and Subnet Mask of your Ewon, based on *Prepare your Ewon for Remote Access, p. 6*.

![Fig. 47 eBuddy — LAN IP address and Subnet mask](image)

8. Click **Next**.
9. Wait until the Ewon reboots.

![Image of eBuddy — Reboot of the Ewon]

10. Click Finish.

### A.2 Step 2: Configure the Ewon Internet Connection

To configure the Internet connection of your Ewon, follow these steps:

1. Link your computer to the LAN port of your Ewon.
   Usually, this link is made through the company network but it can also be made with a point-to-point link.

2. Open eBuddy (if not already open).

3. Highlight the Ewon you want to connect to.

4. Right-click on this Ewon.

5. Select Open in browser.

6. Log in to your Ewon.

7. Click the Wizard button in the top right corner.

8. [Recommended] Go through the System wizard before setting the Internet connection.
   The system wizard lets you change the password of the administrator but also sets the date & time of the Ewon.
   Click the System button in the right-side menu and follow the different steps.

9. Click the Internet button in the right-side menu.

10. Select the WAN interface of your Ewon. The propositions displayed are based on the model of your Ewon.

   **WAN** refers to **Wide Area Network** which is the network covering a broad external area using the Internet infrastructure. It is opposed to **LAN** referring to Local Area Network which is restricted to internal networks.

To continue the Internet step-by-step guide, select your interfaces:

- *Ethernet Connection, p. 37*
- *Wi-Fi Connection, p. 37*
- *Cellular Connection, p. 38*.
A.2.1 Ethernet Connection

1. Make sure the WAN port of the Ewon is physically connected to the company network. The LED dedicated to WAN traffic activity doesn’t blink yet as the WAN connection is not yet defined.

2. Click Next.

3. Select the network management protocol:
   - static;
   - BootP;
   - DHCP.
   
   We recommend using **DHCP**. This way, your Ewon receives an IP address and Internet access automatically from host.

4. Click Next.

5. **Enable** the Internet connection test.

6. Click Next.

The last step of the Internet configuration consist in a communication test.

The **Online IP Check** performed during the connectivity test aims at validating the WAN IP address by reaching a specific domain on Internet on a specific port.

If your network parameters are correct, this test should end up successfully.

If the Internet connection test is not successful, then go back through the previous configuration steps and recheck all settings for compatibility and accuracy.

ℹ️ Your network firewall should allow connections to *.talk2m.com on port 80. Otherwise, the Online IP Check fails.

More information about the configuration of your Ewon for Internet access using the wizard can be found in the **Related Documents, p. 3**.

A.2.2 Wi-Fi Connection

1. Click Next.

2. Enter the name of the Wi-Fi network (SSID) and its password.

3. Select the network management protocol:
   - static;
   - BootP;
   - DHCP.
   
   We recommend using **DHCP**. This way, your Ewon receives an IP address and Internet access automatically from host.

4. Click Next.

5. **Enable** the Internet connection test.

6. Click Next.

The last step of the Internet configuration consist in a communication test.

The **Online IP Check** performed during the connectivity test aims at validating the WAN IP address by reaching a specific domain on Internet on a specific port.
If your network parameters are correct, this test should end up successfully.

If the Internet connection test is not successful, then go back through the previous configuration steps and recheck all settings for compatibility and accuracy.

Your network firewall should allow connections to *.talk2m.com on port 80. Otherwise, the Online IP Check fails.

More information about the configuration of your Ewon for Internet access using the wizard can be found in the Related Documents, p. 3.

A.2.3 Cellular Connection

1. Click Next.
2. Enter the information related to the SIM card and the APN.
3. Click Next.
4. Select the connection type:
   - Maintain connection: your Ewon is permanently connected.
   - Triggered: you must wake up your Ewon by sending an SMS so it initializes the connection.
5. Click Next.
6. Set the call budget if the connection type is set triggered:
   - Idle time: the amount of time before the Ewon shuts down the connection if there is no traffic from/to the Ewon.
   - Call duration: the amount of time the Ewon stays online before closing the outgoing connection.
7. Click Next.

The Online IP Check performed during the connectivity test aims at validating the WAN IP address by reaching a specific domain on Internet on a specific port.

If your network parameters are correct, this test should end up successfully.

If the Internet connection test is not successful, then go back through the previous configuration steps and recheck all settings for compatibility and accuracy.

Your network firewall should allow connections to *.talk2m.com on port 80. Otherwise, the Online IP Check fails.

More information about the configuration of your Ewon for Internet access using the wizard can be found in the Related Documents, p. 3.

A.2.4 WAN Fallback

If another WAN interface is available, a popup appears at the end of the Internet wizard and offers to configure this secondary WAN interface.

If configured, the Ewon switches automatically to this secondary WAN interface in case the primary interface fails.

The configuration of the secondary WAN interface is a replay of the Internet wizard where the proposed settings are based on this second WAN interface type.

More info on the WAN Fallback in the “WAN ConnectionFallback“ from Related Documents, p. 3.
A.3  **Step 3: Create Your Ewon in Talk2M**

This step consists in listing your Ewon inside your Talk2M account using the eCatcher software.

> If you already created your Ewon in your Talk2M account, through eCatcher, you can skip this step and go to the next step.

To create your Ewon in Talk2M, apply the following procedure:

1. Connect your computer to the company LAN.
2. Set the network parameters of your computer to **DHCP enabled**. An IP address is automatically provided from the DHCP server of the company network.
3. Verify that you have an Internet connection. For example: open your web browser and browse to your favorite web page.
4. Open eCatcher if your Internet connection works.
5. On eCatcher’s main interface, click the **+ Add** icon. A new window appears.
6. Enter the name of your Ewon. The Talk2M server displays this name to identify the remote connection to your Ewon.
7. Select the **Connection Type** to specify how your Ewon connects to the Talk2M server. You can choose between two possibilities:
   - Permanent: for Ethernet, Wi-Fi or cellular models. Your Ewon stays permanently online.
   - Triggered: only for cellular models. Your Ewon is offline (but still functional) until you wake it up with an SMS.
     If you specify a triggered connection, then eCatcher asks for the phone number of your Ewon. The phone number allows Talk2M to send an SMS which wakes up your Ewon.
8. Click **Next**.
9. Enter custom information concerning your remote connection. You can use the **Custom Fields** to classify or filter your different remote connections (your different Ewons).
10. Click **Create**.

The newly created Ewon is now linked to your Talk2M account.

eCatcher displays the “Talk2M Connectivity” frame. Follow the **Step 4: Retrieve the Talk2M Activation Key, p. 39** to continue the configuration of the remote access.

A.4  **Step 4: Retrieve the Talk2M Activation Key**

Up to now, we only added the Ewon in your Talk2M account but we didn’t configure the Ewon to connect to the Talk2M server.

One way to enable the link between your Ewon and the Talk2M server is with the activation key. The activation key allows the Ewon to retrieve the VPN keys and certificates useful to establish the VPN connection.

Continue the **Step 3: Create Your Ewon in Talk2M, p. 39** and, in the “Talk2M Connectivity” frame, get the activation key by proceeding as follows:
1. Click the **Copy to Clipboard** button from the **Activation Key** row.

![Fig. 49 eCatcher — Activation key](image)

If you are not in the “Talk2M Connectivity” frame but in eCatcher’s main window instead, follow this process to retrieve the activation key:

1. Select your Ewon in the “My Ewons” list.
2. Click the **Properties** button.

![Fig. 50 eCatcher — Properties of an Ewon](image)

3. Click the **Talk2M Connectivity** button.

![Fig. 51 eCatcher — Talk2M Connectivity](image)
4. Click the **Copy to Clipboard** button from the **Activation Key** row.

![Fig. 52 eCatcher — Activation key](image)

### A.5 Step 5: Connect Your Ewon to Talk2M

To configure the Ewon Talk2M connection, follow the steps below:

1. Configure the network parameters of your computer to fit into the IP range of your Ewon LAN.
   
   If you need help to do this, please refer to [Google®](#).

2. Connect your computer to a LAN port of your Ewon.

3. Open your web browser and target the Ewon internal web page by browsing the LAN address you configured in **Step 1: Set the LAN IP Address of your Ewon, p. 33**.
   
   In our example, that would be: `http://192.168.0.53`.

4. Click the **Wizard** button in the top right corner.

5. Click the **Talk2M — VPN** button.

6. Click the **T2M** button.

7. Insert the activation key copied from **Step 4: Retrieve the Talk2M Activation Key, p. 39**.

8. Click **Next**.

9. Set the advanced configuration if needed. The advanced settings concern:
   
   - the use of a proxy for the WAN connection,
   
   - the obligation to use TCP packets instead of UDP for the WAN connection.

10. Click **Next**.

The last step of this wizard is the Talk2M registration and so the establishment of the VPN tunnel between your Ewon and Talk2M. The following tests are performed:

- the Ewon tests the different connections needed to reach the Talk2M server (UDP/TCP, HTTP with/without proxy),

- the Ewon connects to the Talk2M server and retrieves the VPN keys,

- once the keys retrieves, the VPN tunnel is established.

The result is displayed on the wizard page. Click **Finish** to end the wizard.

Your Ewon now appears online in eCatcher.
A.6 **Step 6: Connect to Your Ewon Remotely**

Now that the Ewon is configured to connect to Talk2M, you can establish the remote connection to this Ewon.

Depending on the type of connection you set, the procedure changes.

### A.6.1 Permanent Connection

To connect remotely to an Ewon tagged as permanent connection, follow the procedure:

1. Connect your computer to the company LAN.
2. Set the network parameters of your computer to “DHCP enabled”. An IP address is automatically provided from the DHCP server of the company network.
3. Verify that you have an Internet connection. For example: open your web browser and browse to your favorite web page.
4. Open eCatcher (if not already opened).
5. Select the Ewon you just configured in the “My Ewons” list.
6. Click the green **Connect** button displayed in the Ewon list menu to establish the remote connection. eCatcher is now attempting to establish a VPN connection to the Talk2M server.
7. Once the VPN connection established, eCatcher displays the Ewon in the “Active connection” section.

The computer is now connected to the Ewon using the VPN tunnel and you can use the remote connection.

You can click the **IP address** link in the “Active Connection” section to display, in a web browser, the homepage of the Ewon web interface.

### A.6.2 Triggered Connection

To connect remotely to an Ewon tagged as triggered connection, follow the procedure:

1. Connect your computer to the company LAN.
2. Set the network parameters of your computer to “DHCP enabled”. An IP address is automatically provided from the DHCP server of the company network.
3. Verify that you have an Internet connection. For example: open your web browser and browse to your favorite web page.
4. Open eCatcher (if not already opened).
5. Select the Ewon you just configured in the “My Ewons” list.
6. Click the green **Wake up** button displayed in the Ewon list menu to wake up your Ewon.

By doing so, eCatcher sends an SMS to switch your Ewon online.

7. Click the green **Connect** button (previously **Wake up** button) displayed in the Ewon list menu to establish the remote connection. eCatcher is now attempting to establish a VPN connection to the Talk2M server.
8. Once the VPN connection established, eCatcher displays the Ewon in the “Active connection” section.

The computer is now connected to the Ewon using the VPN tunnel and you can use the remote connection.

You can click the **IP address** link in the “Active Connection” section to display, in a web browser, the homepage of the Ewon web interface.
A.7 Step 7: Terminate the Remote Connection

Before terminating the Talk2M VPN connection to the Ewon, it is mandatory to change the administrator password which is set by default to *adm*. Please refer to *Login security*, p. 53.

To end the VPN connection and so the remote access to your Ewon, apply the following procedure:

1. Open eCatcher while you are remotely connected to your Ewon.
2. Click the red **Disconnect** button to terminate the remote access.
3. Optionally, leave a log message for future use.

You are now disconnected from your Ewon and can no longer use the remote access.

By disconnecting, you terminate only the VPN tunnel. If you also want to send your Ewon offline (in case of a triggered Ewon), right-click on the Ewon in eCatcher and select **Go offline**.
B  Ewon as PLC Gateway

If the Plug’n’Route function does not work or apply in your configuration, then you need to disable the Plug’n’Route feature in the Ewon and configure manually the Ewon LAN IP address as default gateway in the configuration of the PLC.

To disable the Plug’n’Route function, open the Ewon web interface and follow these steps:

- Click on System.
- Click on Communication.
- Click on Routing.
- Select NAT and TF disabled from the Apply NAT and TF to connection field.
- Click the Update button.
- Reboot the Ewon.

There are two phases to configure the IP addresses in a Siemens PLCs:

**Phase 1**

Phase 1 consists in allocating the new IP addresses to the hardware which enables communication with the PLC.

This configuration is volatile and would be lost in case of PLC reboot or power down.

Phase 1 is done by connecting the Ethernet card to your company network and having SIMATIC Step7® on your PG/PC detecting the IP address of the card to edit its configuration.

**Phase 2**

Phase 2 consists in configuring the new IP address in the project on the PG/PC side and uploading the project (featuring the new IP address) to the PLC.
Alternatively, you can download the Ethernet card configuration parameters using a point-to-point MPI link between your PG/PC and your PLC.

**B.1 Phase 1: Online Communication with the PLC**

Follow the procedure:

1. Connect the Ethernet card of the PLC to the company network. The company network is the network used by the PG/PC configuration.
2. Start SIMATIC Step7®.
3. Open your project.
4. Go to **PLC > Edit Ethernet Node...** from the main menu.
5. Click on the **Browse** button in the *Edit Ethernet Node* wizard. SIMATIC Step7** searches for the connected Ethernet PLC-nodes on the network. Select the node you want to configure from the proposed list.

![Ethernet node selection](image)

*Fig. 55 Ethernet node selection*
6. Enter the **IP address** and **Subnet Mask** of the PLC which has to be in same range than the Ewon LAN.

   Tick the **Use Router** button and enter the Ewon LAN address as gateway.

   Click on **Assign IP Configuration** to send the modification to the PLC.

   Wait for the success message and click on **Close** when you are done.
7. You need to put your PG/PC in the same IP range than the PLC to test the Ethernet communication, otherwise you will not be able to connect.

Right-click on the CPU node, select **PLC > Set Time of Day**.

If the *Set Time of Day* panel appears and timers are increasing, the communication is working alright. If not, check the PG/PC IP range and whether the new IP config in the PLC was retained.

Do not power off or reset the PLC until the new configuration has been embedded in the PLC program (see next phase).

### B.2 Phase 2: Embed the IP Config. in the PLC

The phase 2 implies most of the phase 1 parts but in another environment. This time, you embed the new IP configuration in the PLC itself to make it persistent, not influenced by a power off or reset.

1. Select your **PLC-station object** in the tree of your project.
2. Right-click and select the **Open Object** menu option.

![Fig. 57 Open object for project](image)
3. Step7® opens the hardware configuration window.
   Double-click on the slot table to open the Ethernet card properties.
   In the wizard click on Properties.

Fig. 58 Properties of Ethernet card
4. Enter the **IP address** and **Subnet Mask** of the PLC which has to be in the same range than the Ewon LAN.

   select the **Use Router** option and enter the Ewon LAN address as gateway.

   You can leave the subnet as **--- not networked ---**.

   Click on **OK**.

5. Click **OK** on the error message stating the module is not assigned to a network.
6. Save your changes by clicking **Station > Save and Compile**. Wait until the operation is completed.

   Once OK, the new IP config. is included into the project program on the PG/PC-station, but has not yet been sent to the PLC!

![Fig. 61 Save project properties](image)

7. Click on the **PLC > Download** menu items to transfer the program integrating the new IP config to the PLC module.

   Check the CPU module and click on **OK**.

![Fig. 62 Transfer the project to the PLC](image)
8. The interface opens a node selection pane. Select the node of the Ethernet card meant to interface with the Ewon and click on OK.

Fig. 63 Transfer the project to the PLC — 2

9. A warning states that the CPU stops during the download. Make sure this is not likely to bring any process or person in danger.

   Click on OK.

   When the download is completed, another warning asks whether the CPU should be restarted, click Yes.

10. [Optional] If you want to make sure your parameters are correctly stored:

    – Power the PLC off and on again.
    – Check that its new IP config is well maintained by going to PLC > Edit Ethernet Node > Browse in the SUMATIC Step7® main menu.
Appendix C: Security Aspects

C Security Aspects

C.1 Login security

It is required to modify the login and password of the default administrator which are both adm.

ℹ️ The default adm administrator can be modified but not deleted.

C.1.1 For Ewon Cosy

To modify the default administrator, follow these steps:

- Log in to the Ewon web interface.
- Click on Wizards in the upper right corner.
- Click on System.

![Fig. 64 Change administrator password — 1](image1)

- Set the new password for the Adm user.

![Fig. 65 Change administrator password — 2](image2)

- Click on Next.
- Follow and end the rest of the wizard to apply the new configuration.

C.1.2 For Ewon Flexy

To modify the default administrator, follow these steps:

- Log in to the Ewon web interface.
- Click on Setup.
- Click on Users.
- Click on Adm user.
- Click on Configure.
- Set the new password.
- Click on **Update User**.
D Types of MPI / Profibus Cables

D.1 Cable MPI

As MPI/Profibus cable, you can use the standard Siemens Profibus cables and connectors.

Siemens offers a range of different MPI cable references. One of the basic genuine Siemens references is “6ES7901-0BF00-0AA0”.

There are compatible cables available on the market but don’t necessarily offer the same quality or feature the same functions (e.g.: switchable termination resistors).

HMS Industrial Networks SA proposes a compatible unshielded cable:
- P/N EW40912 - SUBD9/SUBD9 cable for Siemens S7;
- Length: 2 meter;
- Max baudrate: 1.5 MBit/s.

For higher baud rates, use the Siemens genuine Profibus cables with resistor terminations.